Codea 2.1 running code very slowly

upgrade to Ios8 didn’t fix

Hi guys,

I have a similar problem and it seems to be that any cpu intensive code is now running 7-8 times slower than the previous version in my case.

I was waiting for this update hoping to get better performance in my project and start sharing about it, but now that the update makes it an even more impossible project, I guess I’ll just say it :wink: I created a GameBoy emulator, developped entirely in Codea. On my iPad 3, I was getting around 15 FPS and now it’s under 2-3 FPS. I have some initialization code in my setup function (calculating bit operators, etc.) which was taking less than a second, now it’s taking around 8 seconds!

I suspect the new “threaded” rendering…

I could share my code as its probably a very good example of performance drop with the new version of Codea, though I’d first have to remove my links to the roms :wink:

Let me know if that would help!

Hi @jfperusse, I think it helps to know I’m not the only one here. I hope to get some advice because my entire code is trash at the moment.

Here is a link to a discussion on ipad speeds that I started in March. I tried it again and the speed of my iPad Air went from 7.77 seconds to 34 seconds. That’s the same speed as my iPad 1. So there is defiantly a speed decrease. If you ran this back then, try it again and see what you get. @Simeon Something is wrong. I’d rather have the speed back then what was changed that slowed things down.

@deactive @jfperusse @dave1707 sorry about the slowdown. I’m looking into it. Hopefully it’s something obvious that can be fixed in a quick update.

hi @dave1707, I ran that code and it took 119.60 secs.
Earlier comments were talking about 34 and 7 seconds in best cases, how comes it takes now 119 to me? (Ipad 3 Ios8.1)
Does anyone know if there’s trick to go back to Codea 2.0?

@deactive I’m sure @Simeon is hot on the cause and it will be fixed asap.

thank you @Simeon

Thanks @Simeon! That ipad-speeds example is pretty representative of my cpu-intensive setup code as well. Glad to hear you’re looking into it, there’s so much stuff I’d like to share about my other performance issues in my emulator if this issue is fixed :slight_smile:

My iPad 3 on iOS 8.1.1 went from 33 sec previously to 111 sec

@deactive i hit 104seconds on my ipad 3 running 7.x

Out of curiosity, is Codea Scratchpad exhibiting the same performance issue? It’s running a slightly older version of the runtime (still threaded, though).

@Simeon Scratchpad is about as slow. 36 seconds instead of 7.7 .

Thanks @dave1707. Will spend a lot of time on performance for the next update.

I’m having the same issue in my code as well - probably a 50% decrease in performance for what its worth, mostly on mesh related stuff.

I’ll try it in Scratchpad and see what the difference is.

I’m guessing backing out 2.1 and restoring 2.0 might be the best solution in the short term.

I think the best way to achieve that is to back up all your projects / asset packs using iExplore. Deleting Codea and then reloading it from the Codea.ipa file that would be in your itunes mobile applications folder - assuming you’ve got a backup there. Alternatively I’d advise not to upgrade at the moment.

I doubt that any update submitted even in the next couple of days will make it through submission before itunes connect closes on the 22nd :frowning:

I’ve had worse frame rate since the update when there is lots being drawn. Otherwise greate update. iOS 8.1.1 iPad 4th gen

is the update going to take another 7 months to be released? :frowning:

@matkatmusic no

@matkatmusic - that’s a bit harsh dude. You do realize @Simeon isn’t actually under any obligation to do any updates.