[Bug] Codea breaks when running this project

Hello folks,
hi @Simeon,

five minutes ago I worked on my project and right in the middle of typing some code, Codea suddenly broke and closed itself. If I now reopen Codea and tap on my project it breakes again and closes immediately. I can not open my project anymore - just this one! Any other works fine.

Here ist the code of the project:


Inside Layers tab, this was the last line I have written down, before the bug appeared:

("-54x-67_1"):gsub("(%w+)x(%w+)_(%w+)", function(x, y, id)
            print(x, y, id)

Since the Beta expired, I’m using the latest App Store version of Codea.

@se24vad I have the same problem. I tried to paste the code into a project, but it closes Codea every time I try to open that project. I have to leave, so I don’t have time to track it down now, but one thing you can try is to copy little sections of the code and paste them into the project until you reach the section that crashes Codea.

@sv24vad I was able to try some things and the problem is the editor is trying to interpret that line of code and give an error but it can’t and causes Codea to crash.

I changed the above code to this and don’t have any problems with Codea.

string.gsub(str,"(%w+)x(%w+)_(%w+)", function(x, y, id)
print(x, y, id)

@dave1707 thank you for trying out. I think @Simeon has to look into it, since it seem to really be an editor bug. I also experienced another bug: when Undo some action with CMD+Z or software keyboard, it deletes portions of code randomly on any line… weird stuff… - the first editor implementation was more stable.

Anyway, I copied my code and removed the line that caused problems and pasted into a new project. Seems to work again, but the bug is still a problem.