arm64 build issues in Xcode


I don’t know if I am doing something wrong, but I can not build an archive in Xcode if the arm64 architecture is set in the “Valid Architectures”.
If arm64 is set, I get an “Apple Mach-O Linker Error” and a lot of duplicate symbol errors like so :

duplicate symbol l038 in:



duplicate symbol l006 in:



duplicate symbol l002 in:



ld: 424 duplicate symbols for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Any idea ?


@xdamon that’s pretty odd. Can you try exporting a new blank project from scratch and building it? Do you get the same errors?

I have the same problem, it popped up in the past week. I successfully archived an app a week ago but todays app wont work, it only has very minor changes (one or two lines).


@archistudent same question to you: if you re-export a project from Codea now, does it work?

@Simeon I’ll try it now and report back.

@Simeon Tried it with the default codea app exported to xcode, same errors appear. Ill copy it below:

Ld /Users/ysun114/Library/Developer/Xcode/DerivedData/Testforxcode-dxhkshxlqqgaoxefkxeymvkoguhx/Build/Intermediates/ArchiveIntermediates/Testforxcode/IntermediateBuildFilesPath/ normal arm64
    cd /Users/ysun114/Downloads/Testforxcode
    export PATH="/Applications/"
    /Applications/ -arch arm64 -isysroot /Applications/ -L/Users/ysun114/Library/Developer/Xcode/DerivedData/Testforxcode-dxhkshxlqqgaoxefkxeymvkoguhx/Build/Intermediates/ArchiveIntermediates/Testforxcode/BuildProductsPath/Release-iphoneos -L/Users/ysun114/Downloads/Testforxcode/Libs -F/Users/ysun114/Library/Developer/Xcode/DerivedData/Testforxcode-dxhkshxlqqgaoxefkxeymvkoguhx/Build/Intermediates/ArchiveIntermediates/Testforxcode/BuildProductsPath/Release-iphoneos -filelist /Users/ysun114/Library/Developer/Xcode/DerivedData/Testforxcode-dxhkshxlqqgaoxefkxeymvkoguhx/Build/Intermediates/ArchiveIntermediates/Testforxcode/IntermediateBuildFilesPath/ -dead_strip -ObjC -all_load -fobjc-arc -fobjc-link-runtime -stdlib=libc++ -miphoneos-version-min=7.0 -framework iAd -framework GameKit -framework Social -framework Accelerate -framework CoreLocation -framework CoreImage -framework Security -framework CoreMedia -framework OpenGLES -framework GLKit -framework CoreText -framework CFNetwork -framework SystemConfiguration -framework MobileCoreServices -framework CoreGraphics -lz -framework AssetsLibrary -framework CoreVideo -framework AVFoundation -framework AudioToolbox -framework OpenAL -licucore -framework CoreMotion -framework QuartzCore -framework UIKit -framework Foundation -lcodea -ltools -Xlinker -dependency_info -Xlinker /Users/ysun114/Library/Developer/Xcode/DerivedData/Testforxcode-dxhkshxlqqgaoxefkxeymvkoguhx/Build/Intermediates/ArchiveIntermediates/Testforxcode/IntermediateBuildFilesPath/ -o /Users/ysun114/Library/Developer/Xcode/DerivedData/Testforxcode-dxhkshxlqqgaoxefkxeymvkoguhx/Build/Intermediates/ArchiveIntermediates/Testforxcode/IntermediateBuildFilesPath/

duplicate symbol l038 in:

duplicate symbol l039 in:
duplicate symbol l002 in:
ld: 424 duplicate symbols for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Been reading about the error online for the past day, seems its due to a duplicate in the code trying to target two instances of the same class when it archives. A lot of the errors online are due to a .h file with the same name accidentally labelled .m

Thanks @archistudent. Could you log this on the issue tracker? (Link at the top of the forums). This should be fixable without requiring a Codea update.

@Simeon Thanks, I’ve made a new issue tracker for this problem. I am not familiar with xcode apart from submitting a ready built app, how would I be able to manually solve this issue so i can submit my app currently? Normally I would just wait for this to get solved in the next update but the app is used for research by others.

Congrats on 4k posts

@archistudent 4K, I didn’t notice, thanks!

I’m looking into the build issue now. Could you tell me what version of Xcode you are using? (Click “Xcode” in the menu and select “About Xcode”)

@archistudent @xdamon I am unable to reproduce this build error using:

  • Codea 2.3.1
  • Xcode 6.3.1
  • iPad mini 2
  • iOS Simulator

I exported a blank project and compiled it for the above targets. It built and ran correctly.

Do you have any further information that might be helpful?

@Simeon I am using 6.1.1 , perhaps its the version. Ill download 6.3.1 and try again.

@Simeon I’ve just tried it and it can be confirmed that 6.1.1 was the culprit. Updating to 6.3.1 fixes this issue. Perhaps the issue tracker for this bug could be closed now.

Thanks for the confirmation @archistudent

Sorry, I have been very busy and did not check the forum for a while …
Thanks a lot for the answer ! I started downloading the OS X update this morning, as it is necessary for Xcode to update to version 6.3.1 …

5.4Gb = 9-10 hours, and that’s without the Xcode update ! :slight_smile:

Just to let you know, I had several issues updating the OS and Xcode, but in the end, once the updates were done, it worked ! Thanks to all of you …