The selection button on the extra keyboard key bar

I just want to register that I really miss the button that allowed you to move the cursor while making a selection. I find it hard to make precise code selections without it. Am I missing a cunning technique that replaces its functionality? If not, would there be a chance it is put back?

My current method is to use the double-tap facility to select a word near where I want to make a selection and then drag the end points into place. This feels quite clunky.

@LoopSpace If you long press on the screen, a magnifying area shows with the cursor in it. You can then slide your finger around to place the cursor wherever you want. Once you lift your finger, a pop up shows. If you tap Select, then the word that the cursor is in is highlighted. Is that what you’re after.

I’ll give that a go, but where the button was most useful was when I was trying to select something consisting of symbols rather than words.

@dave1707 @LoopSpace - I usually double tap the item I would like to select and it selects it. Often though I need to adjust the selection range especially if there is a . present in the desired selection so I drag the needed small button for extension (the one on either edge of the current selection).

On selection I have noticed recently that dragging selection can often exceed the editing window (like in this forum) extending outside the editing window. Also trying to get the first/final character of a large selection is awkward as the selection area often jumps beyond. I think my finger tips are quite broad making selection difficult - I often appear dyslexic on the phone !!!

@LoopSpace - OK, thanks already posted, tried to do this on iPad and struggled so shifted to Mac and picked the wrong thread dooohhhh!!!

Edit: reply to post below after editing.

@Bri_G @LoopSpace I’ve noticed the over selecting also, but I mostly just ignored it. It seems every time there’s an iOS update, something else gets messed up. Apple keeps adding useless updates and things that worked fine get messed up.

(@Bri_G do you want to repost that in the other discussion to keep continuity?)

@LoopSpace do you use the software keyboard?

If so you can try this:

  • Touch the keyboard with two fingers and drag to move the cursor
  • Tap the keyboard with two fingers and then tap again and leave your fingers on the keyboard to drag a selection (like double tap with two fingers but on the second tap leave your fingers on the keyboard)

@Simeon I tried the tap of the keyboard with 2 fingers and the letters on the keyboard disappears, but the keys are still there. I can’t do anything because the keyboard doesn’t respond to anything and I have to exit the code to get out of the problem. It’s OK when I come back in but I can reproduce it easily.

I tried the double tap on the keyboard again, but this time I still had the letters on the keys but the keyboard was totally unresponsive. Nothing I tried worked. I exited the code and came back in but the keyboard was still unresponsive. I had to close Codea to get the keyboard to work again. It’s version 192.

Hi @Simeon, yes the two-finger stuff works. Thanks!

@Simeon Just had the screen totally lock up. I don’t know if the editor was in a tight loop or it just wasn’t responding to screen touches. Couldn’t do anything. Had to force close Codea. Everything worked OK upon reopening. I’m on ios13.3 and Codea 192.

PS. I was doing cutting, pasting, and editing. It stopped allowing me to edit. I was able to hide the keyboard. After that, nothing.

@Simeon Heres a way I can get the keyboard to go blank every time. Open a new project and move the cursor near the bottom of the text. Double tap on the keyboard and keep both fingers on the keyboard. Raise one finger off the keyboard and then slide the other finger off the screen towards the bottom. The keyboard will remain with letters on the top row but the other keys will be blank.

It might take a few tries to get it to be blank, but once it happens then it’s easy to do. To recover, just run the code.

Another thing I ran into playing with this was at times the keyboard wouldn’t respond to the double tap. The keys on the top row would work, but the lower keys wouldn’t.