Sounds not working at all (SOLVED)

Hi all,

Sounds are not working at all for me. I’m trying several example apps and no sounds are produced.

I tried running other apps and sounds are working. I uninstalled/reinstalled, I rebooted my iPad, nothing works. I’m on the latest iPad, running Codea 2.3.1 (47).

Is this a known issue?


No known issues

Does none of the sound work? Which commands have you tried?

are there any sound files in Codea?

Hey guys,

First of all many thanks for the reply.

I’ve tried many commands, down to the most basic one taken from the help.

function setup()
– play a random jump sound

So I don’t think the issues comes from here. When I open the asset popup and choose sound generator, none of the the choices produce any sound. When I choose advanced, define parameters and click play, nothing happens.

It’s as if the Codea app is not authorized to play sounds…

Other apps produce sounds fine.

Thanks again for the help!

Ok - this is a ashamed reply:( My Ipad was on mute.

Volume was up, other apps (Skype, games) producing sounds, and there’s no mute button on Air 3 so I just assumed mute did not exist on this model anymore, but somewhere on the hidden options there it was… muted.

Sorry for the trouble, and thanks again for the help.