Purchasing Dark Theme causes app to crash


I have purchased the Dark Theme for Codea but trying to activate it causes the app to constantly crash. I then have to delete the app and download again from the app store. It will then ask for my app store password every time I open Codea, if I put the password in the app will then continue to keep crashing until it is removed again. Has anyone else experience this, and is there a work around for it?

Many Thanks

Here is the crash log header:

Incident Identifier: 99896AF2-F128-4C05-BABB-D8503D8D1228
CrashReporter Key: a416cfa7c75d4190c7266550af68e912a11e5b33
Hardware Model: iPad3,1
Process: Codea [791]
Path: /var/mobile/Applications/010515D1-1B76-48CB-A070-B418894F0FA6/Codea.app/Codea
Identifier: Codea
Version: ??? (???)
Code Type: ARM (Native)
Parent Process: launchd [1]

Date/Time: 2012-07-27 16:41:31.765 +0100
OS Version: iPhone OS 5.1.1 (9B206)
Report Version: 104

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x00000000, 0x00000000
Crashed Thread: 0

Thread 0 name: Dispatch queue: com.apple.main-thread
Thread 0 Crashed:
0 libsystem_kernel.dylib 0x30d5e32c __pthread_kill + 8
1 libsystem_c.dylib 0x332ef208 pthread_kill + 48
2 libsystem_c.dylib 0x332e8298 abort + 88
3 libsystem_c.dylib 0x33308cba __assert_rtn + 174
4 Codea 0x001607a4 0x8c000 + 870308
5 Codea 0x00160846 0x8c000 + 870470
6 Codea 0x00160af2 0x8c000 + 871154
7 StoreKit 0x372157a0 __NotifyObserverAboutChanges + 52
8 CoreFoundation 0x3804caf4 CFArrayApplyFunction + 32
9 StoreKit 0x3721575c -[SKPaymentQueue _notifyObserversAboutChanges:] + 112
10 StoreKit 0x37215dee -[SKPaymentQueue _processUpdates:trimUnmatched:] + 1042
11 StoreKit 0x37215026 -[SKPaymentQueue _transactionsRefreshedNotification:] + 42
12 Foundation 0x3730d4f8 __57-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_0 + 12
13 CoreFoundation 0x380c9540 ___CFXNotificationPost_block_invoke_0 + 64
14 CoreFoundation 0x38055090 _CFXNotificationPost + 1400
15 Foundation 0x372813e4 -[NSNotificationCenter postNotificationName:object:userInfo:] + 60
16 AppSupport 0x379bdb9c -[CPDistributedNotificationCenter deliverNotification:userInfo:] + 56
17 AppSupport 0x379bf104 _CPDNDeliverNotification + 284
18 AppSupport 0x379bd994 _XDeliverNotification + 164
19 AppSupport 0x379b2b0a migHelperRecievePortCallout + 166
21 CoreFoundation 0x380d14be __CFRunLoopDoSource1 + 134
22 CoreFoundation 0x380d030c __CFRunLoopRun + 1364
23 CoreFoundation 0x3805349e CFRunLoopRunSpecific + 294
24 CoreFoundation 0x38053366 CFRunLoopRunInMode + 98
25 GraphicsServices 0x36536432 GSEventRunModal + 130
26 UIKit 0x30f04cce UIApplicationMain + 1074
27 Codea 0x0008ee18 0x8c000 + 11800
28 Codea 0x0008edd8 0x8c000 + 11736

Hi @gavinb — do you have the latest version of Codea? If not, try updating it from the App Store, just in case. The latest version is 1.4.3 (you can see it on the credits screen by pressing the Two Lives Left logo in the lower right corner).

Hi Simeon,

I am indeed using the latest version, I have just removed and reinstalled again but still get same issue when trying to restore purchase of Dark Theme.


Have you tried not restoring your purchase, but just selecting the dark theme?

Hi Simeon,

I have indeed, but this does not work either. Since updating to IOS 6 the problem as intensified to the point the app is unusable. As soon as I open the app it now exits straight away.

I have again removed and installed the app with no success:


Thank you for that crash log, @gavinb. I can see why this is happening, though it is strange that removing and installing the app does not fix it.

Do you have in-app purchase disabled in restrictions?

Does Codea still crash if you are online? (Try putting your iPad into Airplane mode and quitting/restarting Codea).

Hi Simeon,

Restrictions are switched off on the device, and Airplane doesn’t resolve either. It’s certainly an odd one


Hi Simeon,

Just an update, but I can get the app to run IF and only if I enable restrictions and restrict in app purchase. If I turn the restriction off it stops working again


Thanks @gavinb. I think I’ve fixed this crash in the next version, thanks to your crash log. Sorry about all the frustration it caused!

That’s ok. It really is no problem :slight_smile: