Prismatic joints

How do I stop 2 bodies with a prismatic joint from not colliding with each other? Is there a way to stop it just passing through?

This isn’t supported right now but I’ll look at adding it to the next release. Because of how Box2D works it would need to be set in the constructor.

@John Ah :frowning: I’ll have to make a workaround for now, I think its a parameter called collideConnected which is set to false by default.

@Luatee: yes this is the property that controls it but it is readonly by default. I’m adding the ability to set this when you create the joint.

Thanks @John!

I’ve created a ticket for this:

This time, I’m pretty sure it hasn’t been fixed yet :smiley:

@toadkick Thanks! Haha I think it will get fixed for the next version :stuck_out_tongue:

did the collideConnected property become accessible in the new version of Codea? It would be very useful.

@piinthesky It can be set to true or false, so maybe it’s fixed.

yes that is true, but it does not seem to work for me. Also it is not documented in the in-editor reference manual.

I’m starting to see that also. I’m still playing around with it to see if it works.

@dave1707 it’s not currently a parameter for physics.body, hopefully it will be added soon.

@simeon, @John, i notice in the issue tracker it says…

changed component to Physics
Due to the way Box2D works this won’t be settable on joints after they are created but there will be an option in the constructor.

what is the constructor? does this mean there is a way to activate this property?