Occasional crash bug related to iparameters and Pause/Reset/Play

I’m getting a Codea crash/exit heisenbug showing up on one of my apps. I have three iparameters Z1 1-4 Z2 1-10 Z3 1-100.

If I launch the app, touch [Pause], [Reset], set the parameters to 4, 6.06, 10.90 respectively and touch [Play] Codea exits and I am returned to the iPad menu.

I can get the same result in a super-simple app with just a background draw and line draw and three iparameters, but it isn’t as reliable, more like 1 time out of 5. With that minimal app I also had the same crash before touching Play.

It isn’t a huge deal for me so I’ve stopped trying to make a minimal piece of code that reproduces it. Just thought I’d mention it here and see if anyone else has experienced anything similar.

Could be related or completely irrelevant:

  • Dragging the parameters and then moving your finger well down, towards the print subwindow before releasing.
  • Fiddling and dragging for 5-20 seconds trying to get 10.90 lol

Codea 1.2.6. I haven’t upgraded yet.


function setup()
  print("Hello World!")

function draw()

  local t=vec(85,97)
  local u=vec2(127,107)


-- Sorry this isn't more minimal this only crashes once every 5-10 minutes of trying
-- making further reductions time-consuming.

Thanks for the sample code @Martin. I’ll try to reproduce this and see what’s happening.

Let me know if you still experience it after upgrading to 1.3.

The more I think about this, the more likely it seems the Pause, Reset, adjust parameters has to be core to the problem. Also, it smells like a race condition.

Thanks for prettifying that code. Should read vec2 obviously. I just speed typed it across - probably quickest. The rest looks solid.

Oh dear Codea 1.3 requires iOS 5 (reasonable enough) which I’m fairly reluctant to put on my iPad 1. Our experience with 5 last month on an iPhone 3GS was that it just felt slower. Hmmm. Hmmm.

I’ve had no issues with 5 on my iPad Gen1. Go for it!


@Martin on my iPad 1 iOS 5 feels fine.

It hard for me to remember back that far but I believe this iPad1 was a bit faster in a few areas with iOS5 and the only time I’ve hooked it to the PC was to quickly copy some music.

OK I shall, not today though, tomorrow. :wink:

I do remember it being a marathon session … Long synch (since I rarely socked even then) … Backup … Long Upgrade with a back up … Long reboot

Yes updating to iOS 5 took a while. The iOS UI feels as fast as iOS 3 and 4 on this iPad 1, so I’m happy.

Codea 1.3: lovely.

I tried to reproduce this bug, I only tried for 5 minutes and my app is different, so not totally conclusive. But I can’t reproduce. Maybe it is fixed with 1.3.