Need report abuse a bug

I don’t know what happens, but I tried to click long the add project tool and I can’t export it.

Long click the project you want to export, not the add project tool.

But at soda or guy


You have to have it in one of your projects before you can export it.

Are you trying to add Soda to your projects by long pressing add projects and it’s not working.

Are you trying to access the “paste into project” feature? “Paste into project” will only appear as an option if the clipboard contains code with at least a --# Main tab.

I want to copy your soda

I clicked the link to download

But there isn’t any

You need to copy the entire contents of the Soda Installer.lua file, and then long press “Add project”, and select “paste into project”

I suspect that your issue is that copy and paste has never worked very well on iOS. Copying lengthy amounts of text from mobile Safari is difficult/impossible. There are a couple of things you can try.

  1. copy the text on a real computer, eg PC/ Mac/ Linux and use a clipboard transferring service to send the clipboard to the iPad. I know it seems ridiculous to have to switch over to a PC just to copy some text, but I find iOS copy and paste to be so terrible, that clipboard managers are essential, in my view. I use one called “command-C”. It just had an update, and seems to work fairly well (though it doesn’t work in the background, even though it’s apparently supposed to: you have to have the app open on iOS to receive a clipboard, I’ve found). I’ve heard good things about “pushbullet”, but I couldn’t get its “universal clipboard” feature to work.

  2. For anything on GitHub, I really recommend the iOS app Working Copy. If you’re just using it to read files (ie import) then it’s free. To push files to a remote there’s an IAP unlock. Copy the URL from the Safari bar of the GitHub repository (or BitBucket, or any other Git service) that you want to import (“clone” in Git speak). Then open Working Copy, press “+”, “clone”, WorkingCopy should auto-detect that you have a GitHub URL in the clipboard and display a “do you want to clone from …” message, hit “clone” again, and the repository will be imported into Working Copy. You can then browse all of the files in the repository, and in the action menu for any file there is a “Copy” button that will copy the entire contents of the file you are looking at.

Can you say me, why don’t your code work, there is smt function Soda.smtinhere() - marked as bug

Because a dot is there

Are you using the installer file?

There is no function called smt or smtinhere

There is a function Soda. (A value I don’t remember)
→ Isn’t working

If you see an error, tap the error in the console to copy it to the clipboard. Then you can post it here. It sounds like you have not copied the entire code into Codea.