Codea Chat Room

Briarfox and I have been working on a project for a little while… a chat room for Codea! I finally said it was polished enough to share with the world, and here it is. When you start, you’ll be asked to enter your name. Enter your Codea Forums username in the “Username” text box, then press “Submit.” Now you can press the bar at the bottom of the screen and type in a message. The chat is synced every second, so you’re up to date.

Installer: Link.

Nice proof of concept :slight_smile:


Here comes the bugs. When selecting Forum in the upper right corner then selecting Done to return back to the chat room, the screen goes black. Codea has to be closed to get back into the Chat Room. Also, can the font size be changed to keep more lines on the screen.

@dave1707 The first is a known bug, it crashes the first time you use the forums button, but after that it works fine. As for the second, try dragging your finger on the screen to scroll. :wink:

… and please add a weapon for dropping a flying cat :wink:

I tried the Forums button 4 times and all 4 times it goes to a black screen when I exit the forum. Is there a way around the black screen or is closing Codea the only way back to the Chat Room. Never mind about the fontsize, I can change that in draw to whatever size I want.

EDIT: I had to change the code so there wasn’t so much space between the lines after I lowered the fontsize. I also removed the supportedOrientation so it worked in portrait mode.

@dave1707 That’s odd about the forums button, it crashed randomly for me, too, once. And the font size does not need to be changed, you can just scroll by dragging.

I changed the fontsize, the space between the lines, and removed the supportedOrientation. So far so good, except for the black forum screen.

The supported orientations call is because it glitches in portrait mode.

The forums button works for me, it’s how i just got here

I’m wondering if there is a bug in openURL() I have this issue in another project. Sometimes closing the url will not continue with the draw loop. That is why the screen is blank. The only fix is to completly clear codea from memory. The draw loop is fired one time after openURL is called. Then it pauses until closed. Sometimes it does not come back.

Anyone know of a fix?

Is there any way to get more to show up? What I mean is, when I go on, I can’t go back and see previous conversation.

I just tried this out and got this error:

error: [string "Server = class()..."]:99: attempt to concatenate field 'user' (a nil value)

Yep, I got that too

Did you enter a user name. If not try adding this to the beginning of setup.

saveLocalData("Chat_User", "your Codea user name")

I got that error too, I just opened up the side window, changed my user name in the text box, and hit the button below, then un paused it and it worked

Odd… I’ll look into it.

@JakAttak You can scroll by dragging on the chat text.

But I can’t go up past when I logged in

I’m uploading a fix right now.