Codea 1.6 Beta

Nice 8-}

Is there an official bug reporter for beta versions, because the bug reporter doesn’t list beta versions (or v1.5.5). Anyways, another bug. When doing Edit>Add to>select one>go back>press cancel, you can’t play that music file.

@Zoyt there is now a 1.6 version on the issue tracker. Thanks for all the bug reports.

Shader issues:

  1. I choose a shader in my code and edit it (so not going from the shader lab). The changes I make aren’t saved.

  2. When in the “Assets” view, it seems that I ought to be able to go straight to the shader lab by clicking on “edit shader” but it doesn’t do anything.

  3. Could we have a “duplicate shader” feature?

Thanks for the bug reports Andrew. I’ll try to add the duplicate shader feature back in as well.

Wow… TLL: Great job. I finally got around to moving my project to the 1.6 runtime (I don’t remember what version it was on before, I think late 1.4 or early 1.5). It runs blazing fast. I’m amazed.
@Simeon - Suggestion: Instead of “readSprite”, “spriteList”, etc. how about “readAsset” and “assetList”. What you do with the function is you pass in the file name, and any extra parameters in a table (like the page number in a PDF), and it returns 2 values: The data and they type. Just thinking out loud.

Nice new assets!
Any chance we get soon the possibility to write some text in the pasteboard?

I’m still running into the tab scrolling problem. Maybe it was there all along, it just was very rare.

Incidentally, I really do not like not having boundaries between the keys on the pop-up keyboard in the editor. Please put them back.

On ios5 i dont see any change in the keyboard.

@Andrew_Stacey I’m a bit confused, which boundaries are missing?

@Simeon Now that’s really bizarre … the keyboard looks like normal now. No idea what happened there. Sorry about that.

I discovered the issue with the scrolling in the tab bars:
I seems that dragging on the top half of the tabs make it so only the velocity fo your drag moves the bar, while dragging on the bottom half acts normally.
Also, long lines of text are still acting weird. Especially when you have the documentation up.

I just updated to ios7 and seem to be unable to work on newly created projects.

  1. I create a new project.
  2. I start to edit code.
  3. I’m instantly back in a folder on desktop
  4. I relaunch codea and I’m in an older project that I had created.
  5. I go to codea home and select the newly created project.
  6. within 5 seconds I’m back on desktop and the issue repeats.

I’m on IOS7 as well but I seem to be able to work on new projects. Have you tried restarting the iPad?

Thanks Andrew. I should have tried that before posting. Killing Codea did not work, but an ipad reboot did.

I take that back. The new project ran but after I exited I could not reopen without a crash. Had to reboot again.

This happens on multiple projects. All of which have been created after updating to ios7. older projects do not seem to be effected.


Sometimes perviously created projects just close back to the Codea home screen as well. This is new with the ios7 update. I havent experienced this in the past. I still can’t open a newly created project for more then 10 seconds before being dumped back to ios home screen.

Resetting the ipad will work until the project is closed. Then another ipad reset is needed to work on it again.

iPad2 16g ios7

@Briarfox very odd, I can’t seem to reproduce this on my iOS 7 device. Does anyone else on iOS 7 experience this?

I’ll keep looking.

Thanks @Simeon. It looks like it may be only me. I’ll try backing up my projects and reinstalling Codea.

When I open a project that was created after ios7 install codea seems to hang. I can see all the code but I can not place the cursor anywhere or edit code. After a few seconds codea crashes.

If I create a new project I can edit it just fine. This breaks on the first time I close codea.

Clearing Codea from memory does not fix it. A restart of the ipad seems to until the project is closed.

@Zoyt I haven’t been able to reproduce that one either. @Briarfox, does that one happen to you too?